Bugfix release – Version 1.3.1h (gapless)

I have recently uploaded Pi Presents version 1.3.1h to Github.

A few people have reported intermittent problems with playing video with the new dbus interface to omxplayer introduced in 1.3.1g. This version hopefully fixes those problems. In addition to fixes to Pi Presents I found it necessary to increase the GPU Memory from the default 64 MB to 128 Mb if playing videos. Instructions on how to do this are in the Release Notes.

Now that Wheezy is unsupported I have removed the requirement to use sudo when using GPIO (actually its use is inhibited). There are also a couple of other minor bug fixes.

Advertisements
This entry was posted in Uncategorized. Bookmark the permalink.

3 Responses to Bugfix release – Version 1.3.1h (gapless)

  1. JC says:

    Hi there Ken!
    This reply is a bit off-topic but I couldn’t find a way to post a new thread…
    First off I’d like to say that the idea behind using a Raspberry Pi for Pi Presents is brilliant.
    I have an issue though with controlling Pi Presents via OSC.
    In the IOPluginManager I get a profile error.
    ‘No DRIVER section in /home/pi/pipresents/pp_io_config/pp_io_confi’
    I have installed gapless and followed the steps in the manual to create an OSC config.

    Please excuse my lack of programming knowledge. I’m a sound and video technician and have not done much in the way of coding.
    But this application could solve a lot of problems with firing remote videos in theatre performances.
    All the IP addresses match up so I can see OSC getting to the pi presents but in the Terminal window I see a few lines that say ‘typetag-string lacks the magic’
    Once again – I’m kind of in the dark.
    Any help or advice would be greatly appreciated.
    And once again – this could be the droids we are looking for. Just need to increase my knowledge of how it works!
    Many thanks, John

    • KenT says:

      Looks like the problem is that you have a pp_io_config directory in the pp_io_config directory –
      /home/pi/pipresents/pp_io_config/pp_io_confi’

      the osc.cfg file should be in the profile in its pp_io_config directory.

      Hopefully the lack of magic is just a consequence of this.

      • JC says:

        Hi again Ken!
        I removed that folder and the warning dialog is no longer present which is great.
        The next issue I have is what exactly is the osc message one needs to send to trigger tracks?
        Essentially – we are using Qlab sending OSC from a mac to the Pi which would then trigger a simple video file.
        I have fixed IP addresses on both machines and can see in the Terminal window on the Pi it is receiving. (But still lacking the magic’.
        When I open the pp_osc_1p3 I can see in the editor Controls examples like pp-play play.
        What do I need to send from Qlab as a UDP message?
        I send ‘/pipresents/osc_1pp3/core/pp-play play’ and ‘/pipresents/osc_1pp3/core/pp-play’ but still the same effect.
        I know that I’m probably doing something super simple stupid but any help for a chap who wants to use this awesome software but has no real programming experience!
        J

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s